Grupo de Usudrios Java | i | GUJ

http://www.guj.com.br GRUPO DE USUARIOS JAVA

Criando sua primeira aplicacao JAVA com o Eclipse

Fernando Boaglio

Instalou o Eclipse mas ndo sabia por onde comecar? Aqui vocé encontra uma breve explicacdo
de como criar sua primeira aplicacdo JAVA no eclipse. Depois de ler esse artigo vocé estara
apto a criar os seus proprios projetos!

Ao contrario do que se pensa, o Eclipse € uma IDE de desenvolvimento ndo sé de JAVA, mas de outras
linguagens também, como o C++ ou o PHP.

O desenvolvimento em JAVA é feito baixando um arquivo adicional que permite a criacdo de projetos
em JAVA, o chamado JDT (Java Development Tools).

Esse arquivo é o mesmo para todas as plataformas que o Eclipse existe: Windows, Linux, Solaris, AIX,
etc.

Vou exemplificar aqui a instalacdo no Linux, supondo que ja foi feita a instalacdo conforme o artigo
Instalando o Eclipse no Linux ou Instalando o Eclipse ho Windows .

Inicialmente vocé fard o download do arquivo necessario no site do Eclipse, que fica na mesma pagina
que foi feito o download do Eclipse Platform Runtime Binary.

Acesse o site:

Localizacao Editar Ver |r Eaveoritos Ferramentas Configuragbes Japela Ajuda

nE20 O L mEmmiEBRAS 8o
B Lgcalizagao:“!_;]http:,’,.'wv.'w.ecIipse.orgfdmnloads,findex.php

feclipse eclipse.org

home .

i i V HP-UX (HP9000/Metif) {http)  (ftp) eclipse-platform-2.1.1-hpux-metif.zip (md5)
consortium _ _
e 5’ Mac OSX (Mac/Carbon) (http)  (Fep) l:nc;Sp)se-pIarform-z.l.l-macosx-carbon.zm {
downloads
articles
newsgroups i
mailing lists These drops contain the Java development tools plug-ins only, with user documentation and no
community source and no programmer documentation. The Eclipse platform and Plug-in development
e environment are NCOT included. You can combine this with the Platform Runtime Binary if your tools
search ;

rely on the JDT being present.

Status Platform Download File

bugs
v‘ All {http)  (ftp) eclipse-JDT-2.1.1.zip (md5) ‘

These drops contain the FTP and WebDAV target management support plug-ins. You can combine
this with the Platforrn Runtime Binary or Eclipse SDK. Includes both source code and binary.
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Versao do Eclipse

Esse texto foi baseado no Eclipse 2.1.1. Hoje temos além de uma versao mais atual da
release 2, ja existe a versao 3 quase final para testes.

Depois de feito o download, descompate no mesmo diretério do Eclipse:

Linux=/java/

Windows=C:\
No linux depois dé os privilégios de uso necessarios:

root@cascao:/java# unzip /download/eclipse-JDT-2.1.1.zip
Archive: /download/eclipse-JDT-2.1.1.zip

creating: eclipse/plugins/org.eclipse.jdt.core 2.1.1/

inflating:

eclipse/plugins/org.eclipse.jdt.core 2.1.1/jdtCompilerAdapter.jar
inflating: eclipse/plugins/org.eclipse.jdt.core 2.1.1/jdtcore.jar

inflating: eclipse/features/org.eclipse.jdt 2.1.1/cpl-v10.html
replace eclipse/readme/readme eclipse.html? [yles, [n]o, [A]ll,

ename: A
inflating: eclipse/readme/readme eclipse.html
inflating: eclipse/notice.html
inflating: eclipse/cpl-v10.html

root@cascao:/java# chmod -R 777 /java/eclipse

root@cascao

Agora inicie o Eclipse. Automaticamente sera detectada a atualizagdo,clique em Finish para continuar a
atualizagao.

Pending Configuration Changes

[}
Check the changes you wish to process now. Remove changes that s hould never ‘5"
be processed.

Detected changes:

13/08/2003 07:58:20 Remove

Error Details

Einish | Cancel
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Sera preciso reinicializar o Eclipse, portanto confirme clicando em Yes:

cle

InstallUpdater

L3
x

You will need to restart the workbench for the changes to take effect. Would
you like to restart now?

Pronto, seu ambiente JAVA estd configurado! Vamos colocar a mdo na massa e criar uma pequena
aplicacao. Clique em Project :

Resolirce - Welcone - Eclipse Platiorm

1
1»
x

Fie Edit Mawvigate Search Proect Run  Window Help
|S-E B & & ¢ |% ara-
1

10 et | v x |[Bwecone x|

p L Foker r Eclipse Java Development Tools (JDT)

SN Fie g [ W= ooF P P

o -

ﬁ‘r Other... This page will help familiarize you with the Eclipse Java development tooling. To get started, read the
' sections below and click on the related links.
) The Java Perspectives
Todo Java development open to the |ava Pers pective Window > Open Pers pective = Java.
Aternatively, if you prefer 2 more browser-like user interface then open 1o the Java Browsing
Pers pective Window > Open Perspective » Java Browsing.
@ Create Java components
To start, first create a Java Project. Mext create a Package within that Project using File = New
= Package (use the Browse... button ta select your project if it is not already listed in Source Folder
field).
To create a Java class, use the Java Class wizard File > New > Class {again use the Browse. .
buttons within the wizard to select the appropriate Project and Package for your class).
B2 ot
@ Dutline b
An outline is not available. @ Installing the Examples
Clicking on http:/fwwaww eclipse org/downloads findex. php opens the Eclipse download page. Select |
a build, s crolldown to the "Example Plug-ins™ section on the upcoming page and foliow the install é‘l
157! Tasks (0 items) OB B ow X
|.f |1. Des cription Resource In Fekder | Location
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Um wizard aparecera com as opcdes de novo projeto, selecione o projeto em JAVA e clique em Next:

e

Select

Selecta wizard

' New Project

Simpke

< Back I Next > I Einish | Cancel

Agora coloqgue o nome do projeto como teste e clique em Finish:

Sl

Java Project

+New' Java Project

Create a new Java projgect.

Projgct name: |teste|

rProject contents
[ Use default

Dire ctory: I,-'jawa,-'eclipse,hmrkspace,-‘teste Bronyse... |

< Back Mext = FEinish I Cancel
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Depois de criado, o Eclipse identificara o projeto como Java e perguntard se vocé deseja que o
ambiente de trabalho (Perpective) se altere para o ambiente de trabalho JAVA. Confirme clicando em Yes
certificando que ele ndo pergunte isso novamente:

This kind of project is associated with the Java Perspective. Do you want to
switch to this pers pective now?

I gc: not s how this message again!

Yes No

Com o seu projeto JAVA criado, vamos criar uma classe dentro dele. Clique com o botdo direito do
mouse em cima do nome do projeto e escolha a opcao New -> Class:

FEie Edit Source Refactor MNavigate Search Proect Run  Window Help
S-HE S| Br-A-w (DA RO ® Y ar
= I8} Package Explorer v X Welcome X | 2= Outline b4
% - e fg | W =$;=. Eclipse Java Development Tools (JDT) An cutline is not available.
=y .
%J‘ W This page will help familiarize you with the Eclipse Java development tooling.
e _ % he sections below and click on the related links.
E} Project...
Go Into T
B ﬁ* Package .
Open in Mew Window N C ectives
2 lopment open to the |ava Pers pective Window > Open
Epen il B fareny i85 Interface e
{,gf-* Cut @, Source Folder U prefer a more browser-like user interface then open
go_py @ S ¢ rank HagE sing Pers pective Window > Open Pers pective > Java
Paste rj'\} Folker
% Dek File o
Source '™ Other... [ate a Java Project. Next create a Package within that
Refactor T = New > Package (use the Browse. . button 1o select
- your project if it is not already listed in Source Folder fiekd).
i3 Import... To create a _Java class, use the Java Class wizard Fik = New = Class
|£| Expert... (again use the Browse... buttons within the wizard to select the
% appropriate Project and Package for your class).
&9 Refresh
Close Progct
{3 Installing the Examples
Team ¥ Clicking on hittp:/jwww e clipse.org/downkoads /index. php opens the
Compare With 3 Eclipse downlkad page. Selkect a buid, s crolldown to the "Example _L_ij
Replace With ’
Restore from Local History... | Tasks (O tems) R :%:b - X
Prope rties / |! |Des cripticn Rescurce iln Folder !Locatbn
Package Explorer | Hierarchy
teste
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Nesse Wizard de criacdo de classes, coloque o nome da classe como teste e crie também o método
main selecionando a opgdo public static void main(String[] args) e clicando em Finish :

Java Class

a Type name is discouraged. By convention, Java type names usually start with an
uppercase ketter.

Source Foder: iteste

Package: | (default

[ Enclesing type: |

Mame: |tes1:e

Medifiers : (8 public " defautt ' private () protected
[ abstract [ final [ Tistatic

Superclass: |j.3va.|.1ng.0hject

Interfaces:

Which method stubs would you like to create?

I~ Epublic static void main(5tring(] args‘.lé

[ Constructors from superclass

[« Inherited abstract methods

Einish |

Cancel

Complete o cddigo gerado com esse exemplo abaixo:

public class teste {

public static void main(String[] args) {

by

System.out.printin("Teste JAVA ' ");
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N&o esquega de clicar no disquete para gravar as alteragdes.Sua classe devera estar como essa:

1k
bt

& (e[ Java - testejava - Eclipse Platform . o

Fie Edit Source Refactor Navigate Search Proect Run  Window Help

|5-[@8 &[5 %% s & Fo-od v e-o-5 48

8 Paciage porer w x || Ejwekome  [FREERTE x| Eome  x
r ' -
& % & H g * Created on 13,08/2003 —||3 28 < o

~ s " Ta change the template for thi di e
"To change the template for this generated file go to B oo :
- : .
(defautt package) *Window&agt Preferencesdgt, Javafgt Code Generation&gt Code anc o~ mainistgl]

» I teste java "

I M, JRE System Library [i2sdk1
IIH‘HE

* @anthor fb

&

=

[»

" To change the template for this generated type comment go to
"Window&gt,Preferencesfigt, Javafgt,Code Generation&gt,Code anc
il

public class teste {

public static void main(String[] args) {
System.out.printin(Teste JAVA ™)
}
it

[«]

57| Tasks (0 ftems) Wom o2 v
|J |! |D|!scriptbr| |Resour.ce |In_FoHer |Locaticm
il [
Package Explorer | Hierarchy
Writable Insert 20:1
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O Eclipse ndo usa o CLASSPATH configurado na sua maquina, ele utiliza um CLASSPATH para cada
projeto. Por isso € necessario criar um perfil de execugdo para rodarmos o nosso teste. Para isso clique no

icone do homem correndo:

e

"¢ TJava - teste java - Eclipse Platfiorm .

Fie Edit Source Refactor

’
] A
Navigate Search Propct Run  Window  Help
5-BEa|sr ke Fo-]e v)we-e- B g B
iz 8! Package Expiarer Run e (1| =1 welcome '5‘| o= Outiine x
& 9 4’ o '+ Created on 13/08/2003 11 E ke e
V‘B‘Jteste [

~ 8 (defautt package)
I Bl JRE System Library [i2sdk]

*To change the template for this generated file go to
* Windowd&gt,Preferences&gt, Javafgt,Code Generation&gt Code anc
o

IIPME

* @ author fb

+

*To change the template for this generated type comment go to
"Windowd&gtPreferencesfgt Javafgt, Code Generation&at Code anc
]

f

public class teste {

pubhc static voud main{String[] args) {
System.outprintin{™Teste JAVA™);

= G* teste

@ " main{String(])
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Nesse novo wizard selecione Java Application e clique em New:
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Create, manage, and run configurations
Configurations:
8 Java Appkt
Jo JUnit
Mew Delete

Close
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Coloque no nome teste.Observe que no campo Main Class foi colocado o nome teste, que é o nome
da classe que sera iniciada de todo o seu projeto.

Como o seu projeto tem uma Unica classe, o Eclipse ja colocou o nome, mas se existirem mais classes
basta vocé clicar em Search para buscar a classe desejada.

Agora clique em Run:

Y ]

Create, manage, and run configurations

Configurations:

Name: Iteste
@ Java Applet
= ZJ Java Application

Ju JUnit

Browse
Main class:
Iteste Search... |

I_ Include external jars when searching fora main class

H Stop in main

d

Dekte Apply Revert

Run Close
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O seu programa sera executado, observe no Console o resultado da execugdo do seu projeto:

———
— A X
Fie Edit Source Refactor Mavigate Search Propct Run  Window Help
IS-HE S| R-R || R RSB 2| e B
iz [2! Package Explorer - % || ElWelome A x| 2= Outlne ®
F i~ s a 5
Byl = @ = 4 * Created on 13/08/2003 o (KT
s TR dfi e
= *Tochange the template for this generated file go to B :
— - : .
& (defaut package) " Window&gt;Freferencesd&gt, Javafagt, Code Generation&gt Code anc " mani gl
» [ teste java "y
I> il JRE System Library [2sdk1
e
!
* @aunthor fb
*To change the template for this genesrated type comment go to
*Window&gt;Preferencesfigt, Javadgt;Code Generation&gt, Code anc
ar
public class teste {
public static void main(String[] args) {
System.out.printin(Teste JAVA ™)
}
l}
=
[4] I
B Consok [<erminated> java/i?sdkl.4 2/binjfjava (13/0803 D8:21)] o BRy 28 4 x
Teste JAVA | -
1] K| I3
Package E:v:|::ulc:urer|Hit!rearchg|r l Tasks |Console!
Writable Insert |2C|:.1

Parabéns, vocé tem uma excelente IDE configurada e em exemplo para vocé fazer os seus novos
projetos JAVA!

Sabendo construir aplicacdes no Eclipse, o seu universo de desenvolvimento ndo tera limites! Crie,
teste, desenvolva e detone em Java!

Fernando Boaglio ( fernando@boaglio.com) é desenvolvedor certificado Java e Oracle com oito anos de experiéncia
no mercado, além de ajudar a comunidade linux ha anos.
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